VPS折腾记:WDCP升级PHP、MySQL、Zend Optimizer

WDCP默认的PHP版本是5.2.17,MySQL是5.1的,对于有点强迫症的我那能接受,并且升级最新版WordPress 3.8时PHP版本过低会出错。所以必须升级,而MySQL最新版本是5.5,于是在升级的PHP、MySQL同时也一起安装相应加速器:Zend Guard Loader、Memcached、eAccelerator。

登陆SSH,本人使用的是Bitvise SSH Client,执行以下命令,一行为一条命令。

1、升级PHP版本至5.3.27

wget http://down.wdlinux.cn/in/php_up53.sh  
sh php_up53.sh

耐心等候,直到“php update is OK”出现。

2、升级MySQL版本至5.5.27

wget http://down.wdlinux.cn/in/mysql_up55.sh  
sh mysql_up55.sh

同样耐心等候,直到“mysql update is OK”出现。此时虽然脚本提示mysql升级完成,但网站无法登陆wdcp后台,ssh下一查连mysql进程都没有启动,如是手动执行mysql进程:service mysqld restart,启动报错:

Starting MySQL... ERROR!   
The server quit without updating PID file (/www/wdlinux/mysql-5.5.27/data/***.pid)

解决方法: 输入命令:vi /www/wdlinux/init.d/mysqld 编辑mysql配置文件,通过vi命令(按i进入编辑模式、按ESC退出编辑模式、输入:wq保存退出)新增加两行如下配置:

basedir=/www/wdlinux/mysql-5.5.27
datadir=/www/wdlinux/mysql-5.5.27/var

或者以下两行代码也可以:

basedir=/www/wdlinux/mysql
datadir=/www/wdlinux/mysql/var

保存退出,重启mysql进程,输入:service mysqld start,启动成功!

3、安装Zend Guard Loader

wget http://down.wdlinux.cn/in/ZendGL_ins.sh
sh ZendGL_ins.sh

然后在PHP.ini文件最后加入配置代码:

[Zend Optimizer] 
zend_extension=/usr/local/zend/ZendGuardLoader.so
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.obfuscation_level_support=3
zend_loader.license_path=[eaccelerator]

4、安装Memcached

wget -c http://down.wdlinux.cn/in/memcached_ins.sh
sh memcached_ins.sh

服务启动或停止

service memcached start|stop|restart

或在后台启动也可以。

5、安装eAccelerator

wget http://down.wdlinux.cn/in/eac0961_ins.sh
sh eac0961_ins.sh

安装完毕后,也需要到php.ini文件最后看看有没有以下配置代码,如果没有,请手工加上。

extension_dir="/www/wdlinux/apache_php/lib/php/extensions/no-debug-non-zts-20090626/"
extension="eaccelerator.so"
eaccelerator.shm_size="8"
eaccelerator.cache_dir="/www/wdlinux/eaccelerator_cache"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="3600"
eaccelerator.shm_prune_period="3600"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"

最后重启服务器:shutdown -r now,然后上传探针看看相应的程序有没有正确运行。最后再次提醒各位,以上命令仅适用于WDCP Linux服务器/虚拟主机管理系统。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

VPS折腾记:WDCP升级PHP、MySQL、Zend Optimizer》上有34条评论

    1. 佐仔

      不要换VPS,我觉得VPS真的折腾人,最主要的是不放心自已的技术能力,怕有安全漏洞,并且时不时1G内存一下子就去掉了900M,一直找不出问题所在,还是找个好的虚拟主机吧。

      回复
    1. 佐仔 文章作者

      折腾不起呀,担心自已的技术能力,虽然WDCP已是一个很好的工具,但不知为什么1G的内存动不动就用完了,所以现在用回虚拟主机。

      回复
  1. CY's BLOG

    我也用的wdcp,昨天在博客开启邮件回复的时候,说“您的主机不支持mail()”,我在想:这是因为没有升级PHP的原因么?btw,博主的wdcp是什么版本的呢?

    回复
      1. CY's BLOG

        当然不是连接出错。。是因为我按照您这篇文章的方法升级PHP和MYSQL,
        在第二点。你提到将出错那里,我也的确是出错了,但是按照你的方法修改那两个文件。。就不能restart mysql服务了。。悲剧啊,都一天了。。刚才又在忙其他事儿~~

        求救。求加Q35269503

        回复
  2. chancat

    你好朋友,谢谢你提供的方法,在升级数据库那个环节出现了点问题 ,重启服务器出现如下错误
    ERROR! The server quit without updating PID file (/www/wdlinux/mysql-5.5.27/data/AY14033115031701815dZ.pid).
    请问这样解决 谢谢

    回复
        1. chancat

          朋友我又来了。。使用的一个程序必须要5.4 和支持5.4的ZEND 我接着升级了,但是出现错误
          “本网站上的一个更多个文件以进行编码ZendGuard和所需的运行时支持未安装orproperly配置。”
          这是需要重新安装zend么 ,用什么命令。。。官方下来回来解压出个.so的文件,
          另外 我在wdcp后台发现 我有三个版本的PHP,这样影响使用么。。郁闷了
          请帮助

          回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注